[Python-ideas] Augmented assignment syntax for objects.
Jerry Hill
malaclypse2 at gmail.com
Wed Apr 26 15:54:22 EDT 2017
On Tue, Apr 25, 2017 at 8:05 PM, Ryan Gonzalez <rymg19 at gmail.com> wrote:
> def ___init__(self, self.attr):
I'm not a python developer, I'm just a developer that uses python.
That said, I really like this form. It eliminates most of the
redundancy, while still being explicit. It's true that you have to
repeat the 'self' name, but it feels like the right balance in my
mind. It seems like anyone who's familiar with python function
definitions would immediately grasp what's going on.
--
Jerry
More information about the Python-ideas
mailing list